General Radio issues

Discussion in 'Lounge & Gossip' started by Baggedcivic99, Wednesday 22nd May, 2019.

  1. Baggedcivic99 Club Member ★ ☆ ☆ ☆ ☆

    Ireland Abigail Ballymoney
    78
    57
    2
    hi everyone, my neighbor came over to the house asking if I could have a look at the radio in her car, it’s a Peugeot 207 or something like that, i was hoping that it was just the aerial plug but when I took the unit out all the wires etc seemed to be secure and the plugs all in, it’s an after market double din with the screen and all that Jazz.

    Anyone have any ideas as to what else could be causing the issue?

    When the radio is turned on it’s just pure static on all channels.
     
    Loading...
  2. RogerH69 Club Veteran ★ ★ ★ ★ ★

    South Africa Roger Oxford, UK
    3,226
    2,169
    17
    Could be the actual cable going to the aerial, or the aerial itself that's dodgy. Only way to really check is to try the radio with a known good aerial and aerial wire. You could try one of those cheap windscreen mounted aerials as a test - just remember these usually need to be wired to power (accessory from radio) and ground.

    Alternatively, if you don;t want to be messing with power cables, get a generic radio aerial like this and plug that into the radio. Stick the aerial itself out the window and you should be good (I had one of these in my Prelude, just lying in the boot, and it got perfect signal)
     
    Loading...
    Baggedcivic99 likes this.
  3. Baggedcivic99 Club Member ★ ☆ ☆ ☆ ☆

    Ireland Abigail Ballymoney
    78
    57
    2
    Thanks @RogerH69, I was going to try another radio to see if it was the things itself, I have a few spare ones in the garage but of course when your looking for something you can never find it :Laughing: every other feature on it works (Bluetooth etc) I unscrewed the aerial to check that it was ok and put it back in, she’s now telling me that she was driving around the coast and it started working but then as she started driving home it stopped working again. When the radio is searching for channels the tone of the white noise is changing which would nearly make me think it’s something to do with the unit itself.
     
    Loading...