Electrical & Lights *Problem* Seats are not heating!

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by TedH77, Wednesday 9th Jan, 2019.

  1. TedH77 Club Member ★ ☆ ☆ ☆ ☆

    Ethiopia tedh7 Vilnius
    28
    8
    Hi guys,

    I have a weird problem, my seat heating is not working properly. In Accord there are HI and LO switches and in mine car seats heat only on LO position (before everything worked fine) so I thought I will buy new switches ( from used car ) but still it only works on LO position, sometimes switch lights are not working properly too. So maybe you can tell me where I need look for a problem? Because I think that issue is not in seats maybe I bought bad switches again. Somebody had this problem too?? maybe someone can tell me how to check if switches are working with multimeter, because I don't know which pin is for what ( I mean, idk which is for HI position and LO position..)

    Thank you for help!

    Sorry for bad English haha!:Smile:
     

    Attached Files:

  2. honda_saj Club Veteran ★ ★ ★ ★ ★

    United Kingdom saj east london
    1,725
    839
    3
    do you knot have wiring diagram ? if not i wil see if i can look up
     
    Loading...
    Nighthawk likes this.
  3. TedH77 Club Member ★ ☆ ☆ ☆ ☆

    Ethiopia tedh7 Vilnius
    28
    8
    No, I don't have anything.
     
  4. DrSam Club Moderator Club Staff

    United Kingdom Sam Birmingham
    2,212
    1,479
    Could be the heating element in the seats that have/are failing.
    Thanks @honda_saj, wiring diagram would help check the switches.
     
    Loading...
    Hondafanat likes this.
  5. TedH77 Club Member ★ ☆ ☆ ☆ ☆

    Ethiopia tedh7 Vilnius
    28
    8
    @DrSam maybe.. but then seats wouldn't heat at all? Are there different wiring for LO and HI positions?
     
  6. DrSam Club Moderator Club Staff

    United Kingdom Sam Birmingham
    2,212
    1,479
    My seats used to get nice and toasty, now they don't, they just get warm even on high. I'm 100% my heating element is going. Not sure if they are different wiring.
    But on your occasion the heating element was just a thought.
    Another thought, could you test with the passenger side switch on the drivers seat and drivers switch on the passenger seat?
     
    Loading...
  7. TedH77 Club Member ★ ☆ ☆ ☆ ☆

    Ethiopia tedh7 Vilnius
    28
    8
    @DrSam I can't switch them, the connections are different for driver and passanger side.:Smile:..
    My seats worked before fine too, but not long ago they stopped to work properly, sometimes driver side worked only on HI postion and passanger only on LO, sometimes everything was fine, but finally everything now is working on LO position (driver and passanger side)
    I hope @honda_saj will find wiring diagram:Wink:
    - - - Updated - - -
    @DrSam Also does your switches are lighting fine?
     
  8. honda_saj Club Veteran ★ ★ ★ ★ ★

    United Kingdom saj east london
    1,725
    839
    3
    Sounds like a wiring issue and that would be common as the seats move back and forth i would check wiring under seats while i dig up diagram anyone know what engine code tsx is ?
     
    Loading...
  9. DrSam Club Moderator Club Staff

    United Kingdom Sam Birmingham
    2,212
    1,479
    Lights on the driver side switch is loose. So sometimes temperamental, heated seats come on but no light.
     
    Loading...