haelp on this please. car is drinking like a fish.

Discussion in '6th Generation (1996-2000)' started by Darcy, Saturday 26th Dec, 2009.

  1. Darcy Senior Member ★ ★ ☆ ☆ ☆

    344
    right.. for the last few days my car has been drinking fuel like a fish. (EJ9)


    there is no differance in how i drive or how it drives, no smoke, leaks etc..


    i was getting around 90-95miles on
     
  2. Jasonday2007 Club Veteran ★ ★ ★ ★ ★

    give it a good service and check everything making sure you have no leaks :Smile:
     
  3. Darcy Senior Member ★ ★ ☆ ☆ ☆

    344
    it was serviced less than 500mile ago and the engine is bone dry (out side that is)
     
  4. Smiley Club Veteran ★ ★ ★ ★ ★

    i'd still check everything. The service may not have been done properly. Also do you run with a cat or decat. Is your o2sensor faulty/connected. Any engine check lights?
     
  5. Darcy Senior Member ★ ★ ☆ ☆ ☆

    344
    i did the service myself so yh. run with cat and 02 sensor is fine, no lights etc.


    fuck it ill just take the car out and floor it everywere it will sort its self out after. think what the car is telling me is..... get this shitty d14 out of me :Smile:
     
  6. Jasonday2007 Club Veteran ★ ★ ★ ★ ★

    it may just have something clogged up in/on a sensor so it's seriously over fuelling to compensate?


    Mine is getting about 10mpg less than when I got it, but is due a service.


    Did you change your fuel filter?


    Can always try re-setting the ECU too :Smile:
     
  7. stu1.4 Valued Contributor ★ ★ ★ ☆ ☆

    mine has developed the same problem, has recently been serviced and nothing is different on the car, baffles me :/
     
  8. Jasonday2007 Club Veteran ★ ★ ★ ★ ★

    punch it in the rocker... it'll soon sort it's life out and stop giving you jip :Wink:
     
  9. Smiley Club Veteran ★ ★ ★ ★ ★

    Quality advice, but i like to use a hammer
     
  10. Darcy Senior Member ★ ★ ☆ ☆ ☆

    344
    what sive hammer??? will this do??


    big_hammer.
     
  11. RichieB Senior Member ★ ★ ☆ ☆ ☆

    436
    My ej9 is doing the same, put it down to it been so cold and using more fuel
     
  12. LiggyL Club Veteran ★ ★ ★ ★ ★

    Exactly what I was gonna say, always get noticeably less this time of year!
     
  13. Shib786 Top Contributor ★ ★ ★ ★ ☆

    urgh, lucky you, my b16 gives me 50 miles to a tenner....thats without too much VTEC :Tongue:
     
  14. LiggyL Club Veteran ★ ★ ★ ★ ★

    50 miles to a tenner?! Nice work haha I normally get about 65!
     
  15. Darcy Senior Member ★ ★ ☆ ☆ ☆

    344
    i would not be fcuked if i got 50miles to
     
  16. Shib786 Top Contributor ★ ★ ★ ★ ☆

    :Angry:


    Yeah!?!?! ohmy :Frown:
     
  17. Gav_ek4 Top Contributor ★ ★ ★ ★ ☆

    buft i get about 80miles tops to 20quid in my vti,but then again it practically lives in VTEC when it gets its daily blast to work lol


    my old ej9 would struggle to see 60 miles to a tenner
     
  18. Krim Club Member ★ ☆ ☆ ☆ ☆

    77
    my ej9 would get about 65-70miles to a tenner,and sometimes putting my footdown..my 1.6 saxo i had while bk used to give me 100miles to a tenner lol.... maybe cos it was only 8 valve.
     
  19. eca Valued Contributor ★ ★ ★ ☆ ☆

    900
    yeah mines the same problem. but I've noticed mine doesnt warm up properly...is due a service aswell. maybe the thermostat?
     
  20. gumbar Top Contributor ★ ★ ★ ★ ☆

    D16z6 ej9 ftw! 38mpg at the moment with a fubard intake manifold gaskt, leaking exhaust and stil the use of VTEC y0! lol