Engine & Gearbox eg6 fuel pump won't prime??

Discussion in '5th Generation (1992-1995)' started by PonnyJ, Friday 4th Dec, 2009.

  1. PonnyJ Club Member ★ ☆ ☆ ☆ ☆

    90
    had the car off the road for a while and went to start it the other day, turned the key and no noise from the fuel pump :Messed:


    tried putting a new battery on it and no difference


    if anyone has any ideas they would be greatly appreciated
     
  2. ek-greeny Club Veteran ★ ★ ★ ★ ★

    could be main relay mate, sounds like the most likely cause
     
  3. Sam. Club Veteran ★ ★ ★ ★ ★

    Most likely the main relay.


    I've got a working one here if you do need one.
     
  4. smithy13 Club Member ★ ☆ ☆ ☆ ☆

    96
    What is the CEL light doing? Is it staying on? If it goes off after two seconds its possible that your main relay has packed in.


    If its stays on after two seconds could be possible ECU in a worst case scenario.


    Check earth strap on the back of the thermostat housing
     
  5. PonnyJ Club Member ★ ☆ ☆ ☆ ☆

    90
    CEL light comes on for 2 secs then goes off as usual, how do i check if it is the main relay? any way of telling by looking at it or do i just need to put a new one in and try that?
     
  6. ek-greeny Club Veteran ★ ★ ★ ★ ★

    You can open them up and re-solder the damaged joints
     
  7. PonnyJ Club Member ★ ☆ ☆ ☆ ☆

    90
    right well i'll check that in the morning when its light enough to see again
     
  8. Civboy@JSP Commercial Services Trader

    just get a new main relay for how much they are best off gettin new common thing on EG's


    done it on my other EG use to have to slap the bottom of the dash for it to work till i got a new 1 lol
     
    Loading...
  9. PonnyJ Club Member ★ ☆ ☆ ☆ ☆

    90
    right, just finished re-soldering the main relay, still no luck with the car starting, no fuel pump whir but car cranks
     
  10. jscivic Top Contributor ★ ★ ★ ★ ☆

    i just got a new 1 mate
     
  11. ek_civic_brum Valued Contributor ★ ★ ★ ☆ ☆

    631
    new ones are about
     
  12. daz-civic Club Veteran ★ ★ ★ ★ ★

    people forget about the main relay cause the common fault with relays was on 4th gens and CR-X's the EG's onwards use a different design relay that cured the fault


    first thing you cold do is pull the pump over off and earth the pump as this will switch it on and make it run all the time and if it does run then start looking elsewhere but if not then obviuosly its the pump itself
     
  13. smithy13 Club Member ★ ☆ ☆ ☆ ☆

    96
    If it didn't work with the re soldering. Try giving the engine grounds a clean. There's 1 by the negative battery terminal. One on the rocker cover. One on the gearbox and one on the thermo housing on the back of the engine.


    There's also the ground for the fuel pump under the drivers seat. If it does not start then try swapping the pump.


    Still if nothing, try swapping ECU with someone jus for a try.
     
  14. Chesh Club Veteran ★ ★ ★ ★ ★

    fuse, check it


    i thought mine was fucked changed the fuse and now its fine
     
  15. ek_civic_brum Valued Contributor ★ ★ ★ ☆ ☆

    631
    i used to work at honda and sold a lot of main relays on EG's plus 2 have failed on me on my 2 previous EG's. they are a common fault.
     
  16. Darcy Senior Member ★ ★ ☆ ☆ ☆

    344
    could it not just be the cut off switch, mine was not priming on my ej9 it had tripped out, worth a try.
     
  17. ek-greeny Club Veteran ★ ★ ★ ★ ★

    EG's don't have them mate
     
  18. PonnyJ Club Member ★ ☆ ☆ ☆ ☆

    90
    got a new relay in the car, still no prime from the fuel pump


    done a CEL light check and an error 41 came up (O2 sensor??)


    assuming this wouldn't stop the car from starting so gonna have to look at new pump :Frown:
     
  19. Jonnay Club Veteran ★ ★ ★ ★ ★

    try cracking the nut on the fuel filter mate see if the rail is holding pressure, my friends is doing thsi atm it won't prime whilst there's pressure in teh rail, crack the nut and let it release and it will prime right up (once you redo the nut of course lol)


    not sure what causes it though :Frown:
     
  20. smithy13 Club Member ★ ☆ ☆ ☆ ☆

    96
    You got any mates with the same car as yours? Try swapping ECU's. That may be the problem. Do not start the car though. Just see if it primes with another ECU. If it does then ECU might be knackered. If it doesn't then look elsewhere.