Engine & Gearbox ECU Code P1279 VTEC system malfunction Bank 2

Discussion in '2nd Generation (2002-2006)' started by BrettW, Saturday 24th Aug, 2019.

  1. BrettW Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Brett Bracknell
    9
    6
    Hi all me again after all my parts replacements over the last month, I finally got my CR-V running nice and sweet and then the Engine light came on (first time I have seen it since owning the car)
    Had it diagnosed as P1279 does anyone know how to treat this and if so what part do I need

    its showing as a VTEC spool assembly with oil pressure switch but just wondered if anyone else had experienced the same problem

    rgds

    Brett
     

    Attached Files:

  2. andy83 Club Veteran ★ ★ ★ ★ ★

    United Kingdom andy shropshire
    4,547
    2,830
    3
    Loading...
  3. BrettW Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Brett Bracknell
    9
    6
    thanks Andy I know the americans had recalls on a few models but am going to give it a good clean and maybe an oil change to see if that makes a difference
     
    andy83 likes this.
  4. andy83 Club Veteran ★ ★ ★ ★ ★

    United Kingdom andy shropshire
    4,547
    2,830
    3
    if i'm right mate it will be related to it and not something else so worth checking it fully also oil level ECT..
     
    Loading...
  5. BrettW Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Brett Bracknell
    9
    6
    yes I have a new oil filter too so will chuck that on to make sure
     
  6. andy83 Club Veteran ★ ★ ★ ★ ★

    United Kingdom andy shropshire
    4,547
    2,830
    3
    have you checked around the solenoid ...
     
    Loading...
  7. BrettW Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Brett Bracknell
    9
    6
    not yet will be off the car within the hour tho for a full de-grease
     
    andy83 likes this.
  8. andy83 Club Veteran ★ ★ ★ ★ ★

    United Kingdom andy shropshire
    4,547
    2,830
    3
    ok mate hope it can all be any easy fix.
     
    Loading...
  9. gman88667733 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom George Devon
    27
    7
    Did the engine light just come on randomly? Before I got my CR-V, when I test drove it, if you revved it over 4000 RPM or something like that it bogged down and the engine light came on, the fault was a VTEC solenoid, they said it was a very easy job and it was sorted quickly and hasn't been an issue in the 1000 miles or so since we have had it.
     
  10. MattBeardless Service Team H-Tune Staff

    It'll sound like an odd response, but have you checked the filter in the VTEC Solenoid Gasket? If that's blocked, it'll stop VTEC engaging properly as not enough oil will get into the system to engage the higher lift cam lobes.
     
    Loading...
  11. BrettW Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Brett Bracknell
    9
    6
    ok all done yes it was the solenoid have got a new one to put on but cleared the old one and it works fine. Will change this weekend and do a full oil change to boot. thanks once again everyone this car is most certainly a labour of love
     
    MattBeardless and andy83 like this.
  12. andy83 Club Veteran ★ ★ ★ ★ ★

    United Kingdom andy shropshire
    4,547
    2,830
    3
    A good old honda :Smile:
     
    Loading...
  13. MattBeardless Service Team H-Tune Staff

    Just to confirm, was that the little bit of mesh in the gasket being blocked?

    Glad to hear it's sorted.
     
    Loading...