Dx hatchback carb problem

Discussion in '5th Generation (1992-1995)' started by Mike88, Friday 20th Nov, 2009.

  1. Mike88 Valued Contributor ★ ★ ★ ☆ ☆

    Hey ppl, am not sure if I'm on the right section, but I've got a problem with the carb (it's been overfuelin) causin engine cuttin off at low revs:Tongue: also I need to find the part for it. Does anyone knw were I can find/buy another carb for my 95 Civic dx hb. Cheers. Pat
     
  2. Rojer Club Veteran ★ ★ ★ ★ ★

    Hi mate i had the same problem with my DX kept cutting out at low revs i thought it was that the engine wasnt getting enough air, i picked one up at my local scrapyard cost me
     
  3. Dan Club Veteran ★ ★ ★ ★ ★

    United Kingdom Dan Oldbury
    3,806
    57
    Before you go changing stuff, When was the last time you cleaned the carb out?


    I've just got myself an EC which is the first carb'd motor I've ever owned, And i had similar issues with the cold setting in, I wacked some carb cleaner down it, and it seems to have fixed my issue!
     
    Loading...
  4. Rojer Club Veteran ★ ★ ★ ★ ★

    Hmm well mine on cold sometimes the revs drop under 1k and start going up and down i think its down to my huge exhaust aswell lol, but yer ill get some carb cleaner too.
     
  5. JDM_Pat Guest


    Hmm.. it seems similiar problem with the air sensor, my mate took a look, fiddled and used the carb cleaner'd and then told me it possibly could be somethin wrong with the air sensor goin into the filter which caused the engine to cut off at low revs, (which he had to engine runnin with his finger blocking the pipe, the engine runs ok, but then when he lets go it dies off) so now hes blocked that piping off an seems good. But still uncertain bout it tho. I am quite :fingers: hoping that the engine won't cut off again.


    What do you think i shud do?
     
  6. JDM_Pat Guest


    On cold weather my engine revs up to at least just above 1k till it gets warm then goes back to normal revs, I've got a de-cat & BC spec 2 pipe.
     
  7. Dan2020civic Club Veteran ★ ★ ★ ★ ★

    A friend of mine had this same problem, we disconnected the pipe and blocked it off, it ran fine then.


    It's the idle control valve that sticks. I've got a spare one here that I got for him but he crashed his car before he could use it!!


    PM if of interest.
     
  8. Zoaib Club Veteran ★ ★ ★ ★ ★

    i got the exact same thing on my bali. it usually idles at around 350 ish man :Frown:
     
  9. JDM_Pat Guest


    Yeah mate sure will get in contact with u, my car is in the garage atm gettin serviced and cambelt changed so just waitin on if itll do it again. Cheers
     
  10. JDM_Pat Guest


    mine did that when it wasnt in a good state then it just conked out, until my mate blocked off the air pipe its gone back to normal and seems good now. :fingers:
     
  11. Zoaib Club Veteran ★ ★ ★ ★ ★

    i cleaned out my carb today, and i was fukin about with the choke. when the choke was up (restricting air), it reved to about normal idle. but if i let it go, it went back on the low revs/ passing out point.


    How do i block off the air pipe, will this be a permenant fix?
     
  12. JDM_Pat Guest

    My mate just simple, put in a rubber screw at the end pipe :Tongue:
     
  13. Zoaib Club Veteran ★ ★ ★ ★ ★

    u reckon i can get away with stuffing scrunched up news paper in the pipe?
     
  14. JDM_Pat Guest

    If u can get it to fit in it to block the pipe then i guess soo.
     
  15. Zoaib Club Veteran ★ ★ ★ ★ ★

    are u talking about the big pipe going into the air cleaner part yh?