Feedback/Help CR-V 2.2 CDTi turbo problem

Discussion in 'Feedback, Help & Suggestions' started by TJTicketyboo, Wednesday 6th Mar, 2019.

  1. TJTicketyboo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Tom London
    7
    Hi all
    The turbo on my 2005 CR-V CDTi is not kicking in till 2500 RPM. The car is very sluggish up to 2.5k revs then it flies with absolutely no issues.

    Any ideas what I should be looking at?

    Thanks
    TJ
     
  2. Zebster Club Veteran ★ ★ ★ ★ ★

    Are you measuring the MAP sensor reading to determine that the turbo is producing no boost until 2500 RPM? Does it start ok and have the usual fuel economy?
     
  3. TJTicketyboo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Tom London
    7
    No, I'm assuming it's the turbo as the car is very sluggish up to 2500rpm then I can hear the turbo and normal service is resumed.
     
  4. TJTicketyboo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Tom London
    7
    I haven't checked anything yet. The car is very sluggish at low revs then picks up at 2500 RPM and I think I can hear the turbo kick in.
    Urban fuel economy is reduced but motorway is great (I.e. when cruising around 3000 RPM)
    - - - Updated - - -
    I haven't checked anything yet. The car is very sluggish at low revs then picks up at 2500 RPM and I think I can hear the turbo kick in.
    Urban fuel economy is reduced but motorway is great (I.e. when cruising around 3000 RPM)
     
  5. Zebster Club Veteran ★ ★ ★ ★ ★

    So does it start ok?

    Did this problem come on suddenly? What had happened just before the problem came on?
     
  6. TJTicketyboo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Tom London
    7
    It starts and runs fine, just no acceleration until it slowly gets to 2500 revs. To be honest I really can't remember what happened when it started.
     
  7. Zebster Club Veteran ★ ★ ★ ★ ★

    So how long has it been doing it?

    I feel like I'm trying to get blood from a stone here... nobody can help you unless you're willing to be a little more forthcoming when describing the problem!
     
  8. TJTicketyboo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Tom London
    7
    Sorry, I've answered your questions as best I can. I've told you what's happening and that I can't remember when it started. Perhaps I shouldn't have asked the question if I'm putting you out.
     
  9. Zebster Club Veteran ★ ★ ★ ★ ★

    I'll stop bothering you.
     
  10. leonard Senior Member ★ ★ ☆ ☆ ☆

    leonard london
    206
    78
    This issue sounds like the EGR is blocked.
    It’s worth checking this first.
     
  11. TJTicketyboo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Tom London
    7
    - - - Updated - - -
    Thanks Leonard. That's a great starting point.
     
  12. SpeedyGee Club Manager Club Staff

    England Speedy Birmingham
    17,185
    7,569
    5
    No now boys, let not have a fight here. Let's put this down as a communication issue and move on.

    @TJTicketyboo @Zebster is very knowledgeable on diesel, he can help you out for sure.
     
    Loading...
    DrSam likes this.
  13. ACC-CDI-2T Valued Contributor ★ ★ ★ ☆ ☆

    Cologne
    356
    360
    1
    Often the problem is just the fuel filter... When it was replaced last time?​
     
    Last edited: Friday 15th Mar, 2019
    Loading...