Pre-Facelift Model car vibrating in idle with AC on

Discussion in '8th Generation (2008-2015) [Acura TSX]' started by ZeroZ, Thursday 2nd May, 2019.

  1. ZeroZ Club Member ★ ☆ ☆ ☆ ☆

    Netherlands erik Rotterdam
    39
    31
    Hi Guys,

    Just as the title says, when idling the car like in front of a traffic light, the entire car is vibrating just enough to get annoyed about.
    This is noticable when the compressor of the AC kicks in. With the AC off its running very smooth.
    The RPM with the AC on or off seems always the same, 750-800 RPM.

    did any of you experienced this before and if yes did you manage to solve it?

    Many thanks in advance
     
    Loading...
  2. jd1959 Top Contributor ★ ★ ★ ★ ☆

    Ireland Zack Kilkenny
    552
    315
    A couple of thoughts of where to start for the vibration, valve adjustment, belt tensioner, engine and transmission mounts.

    Not sure but I think the idle on those is 800 plus or minus 50 RPM when hot. If you could get a reading through the OBD port you could keep track a bit more accurately to see whats happening with the idle and throttle position. I don't think the R20 has an iac and idle speed is done via the throttle plate so being able to see the % change when the compressor kicks in to keep the idle steady might confirm all is working correctly.
     
    Loading...
  3. ZeroZ Club Member ★ ☆ ☆ ☆ ☆

    Netherlands erik Rotterdam
    39
    31
    cheers Zack for your reply,
    unfortunately I have to rely on my Honda garage so to get a reading from OBD myself won't be possible.
    the first thing the dealership wanted to do is to change the spark plugs and the bobines which I objected because they where changed last year with normal maintenance and that didn't change thing.
    "A couple of thoughts of where to start for the vibration, valve adjustment, belt tensioner, engine and transmission mounts."
    valves have been done so I will tell them to look at other suggestions you put in the post.
     
    Loading...
  4. Matt at H-Tune Service Team H-Tune Staff

    Hey @ZeroZ - Have you checked the pulley itself? It may be that the bearing in the compressor is bad, which would cause the pulley to wobble. I have a similar issue with the PAS pump on my Del Sol.
     
    Loading...
  5. ZeroZ Club Member ★ ☆ ☆ ☆ ☆

    Netherlands erik Rotterdam
    39
    31
    Hi Matt,

    cheers for the tip. I will certainly have a look at it.
     
    Loading...
  6. Deftas New Member Getting Started

    Lithuania Deft Šiauliai
    2
    Hey Zeroz,

    Did you fixed that vibration problem? Im having same issue, high vibration on gear that idle.. Valve adj. ok. Mounts was checked and seems to be ok. Its only starts vibrate then drops RPM to certain range, even AC is turned off..
     
  7. ZeroZ Club Member ★ ☆ ☆ ☆ ☆

    Netherlands erik Rotterdam
    39
    31
    No I haven't found the time yet.
    Note though that I do not have the issue when the AC is off
     
    Loading...
  8. Deftas New Member Getting Started

    Lithuania Deft Šiauliai
    2
    What is normal idle RPM should be for 2.4 on right working temperaturo of engine? 650~?