brake problem

Discussion in '6th Generation (1996-2000)' started by Shamsu, Tuesday 17th Nov, 2009.

  1. Shamsu Valued Contributor ★ ★ ★ ☆ ☆

    417
    I have a mb6. When I first bought it the brakes had problems. Everytime I would push the brake pedal the whole car will shake includng the steering wheel and the pedal. I changed the discs and it was fine. 20,000 miles on the problem is coming back. Any idea what it could be?


    Thanx.
     
  2. al9955 Club Veteran ★ ★ ★ ★ ★

    4,590
    31
    sounds like it was warped discs the first time and the same has happened again!, do you do a lot of heavy braking?


    al9955
     
  3. the mechanic Valued Contributor ★ ★ ★ ☆ ☆

    i agree its warped discs did you buy cheap pattern part discs? or good quality parts.
     
  4. HondaR84 Senior Member ★ ★ ☆ ☆ ☆

    357
    Warped disc again for sure
     
  5. pickles2010 Valued Contributor ★ ★ ★ ☆ ☆

    577
    warped discs mate !!


    your hubs might be slighty off so warping your discs u could get new discs or get your discs skimmed to skims to ya hub then be fine
     
  6. Shamsu Valued Contributor ★ ★ ★ ☆ ☆

    417
    Hmmm thanx guys. They were manufactured by blueprint cost me
     
  7. chelt_scene Club Veteran ★ ★ ★ ★ ★

    yeah same thing as my motor mate warped disks it is proper annoying ino fucking earthquake on your pedal and wheel lol
     
  8. kingy18 Club Member ★ ☆ ☆ ☆ ☆

    245
    sorry to revive this, but did you ever find out what it was?


    my EG has the same thing but I've changed the discs and its exactly the same?


    could pads be the issue?