Engine & Gearbox b18c4 swap, interesting vtec problem.

Discussion in 'Honda B-Series' started by turbofish, Thursday 18th Aug, 2011.

  1. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    hi guys,


    I've completed a b18c4 swap into my ej9 with an EK9 loom. I'm using a socketed p28 with a H-tune b18c4 base map and bridged wiring loom adaptor.


    i have no VTEC on the first start up and drive it gets upto temperature no CEL codes are present but it will not engage.


    once its warm if i then turn the engine off , either leave the ignition on or remove the key when i then start it again and drive it the VTEC works. done it 3 times now.


    i've driven the car with out turning it off and back on and only on one of the drives did the VTEC start to work. once the VTEC starts working it continues to work for the remainder of the journey.


    the cross over is very noticable when it works and the pull is very good, not my first b series so i can definatly confirm that it is working when it decides to lol :headbang:


    there is one plug left on the EK9 loom but have no sensors left to lug it to. and can't see this as the problem as the VTEC works after its warmed up been switched off and back on.


    any ideas??


    thanks


    matty
     
  2. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    the remaining plug is on a longish wire that comes out the main loom under the inlet manifold. it has a two pin round plug on the end of it.


    coolant temp gauge seems to be a bit odd today goin up and down no VTEC at all even when switched off. cleaned the plug on the sensor see if that helps looked a little corroded but still no joy.


    car is getting warm and hot air is blowing so has coolant circulation. rad is also warm so thermostat is opening, could be worth changing.


    VTEC worked in the mb6 that the engine is out of as well and had no coolant issues either. i'm using all the cooling system i.e that rad fan and pipes.
     
    Last edited by a moderator: Thursday 18th Aug, 2011
  3. kowalski Club Veteran ★ ★ ★ ★ ★

    james scotland

    sounds like the plug for the EVAP canister purge valve. Black plug?
     
    Last edited by a moderator: Thursday 18th Aug, 2011
  4. H22_Dan.. Club Veteran ★ ★ ★ ★ ★

    Long shot but does your speedo work all the time ?
     
  5. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    its a grey plug. could well be still got the d14 canister. the loom is off an EK9. if not plugged in could this cause an intermitent VTEC issue


    yeah my speedo is working all the time had to remove the kph/ mph converter but it works perfectly.
     
    Last edited by a moderator: Thursday 18th Aug, 2011
  6. kowalski Club Veteran ★ ★ ★ ★ ★

    james scotland
    Shouldn't cause a VTEC issue, just trying to identify the plug for ya :Wink:
     
  7. carlsberg Club Veteran ★ ★ ★ ★ ★

    what colour wires is on the plug. on imports they have a sensor on the power steering pipes coming up from the rack which this would plug into. uk cars don't have this so that could be the spare plug you have
     
  8. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    sounds about right, is about that length,
     
  9. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    hey guys, been using the car a bit more now. still the same problem.


    on the 1st start and drive there is no VTEC even when upto temp. what i have noticed is that the idle speed remains high, at above 1200rpm.


    once the car is warm after that drive i can turn the ignition off for a few seconds take the key out then restart the car the idle speed drops to about 800-1000rpm, now when i drive the car the VTEC works fine the whole time until the engine is turned off. on restart if the temp has dropped same problem.


    any ideas?? no CEL codes. could it be a bad map?? dodgy idle speed control valve??
     
  10. EK4chris Top Contributor ★ ★ ★ ★ ☆

    alright mate its chris got the spec 2 off ya, could either be one of the idle speed control valve, did you get the h tune chip done yourself or was it from somebody else mate.
     
  11. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    got it straight off h tune. didnt have the problem in the mb6 and the h tunes socketed ECU was in my mates ek4 with a different chip and that was fine.


    how you gettin on with the spec 2?? loud innit!!
     
  12. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    tried a different chip still the same problem, car gets warm still idles high 1500 RPM ish no VTEC :disbelief , turn off wait a second turn back on idle speed drops down to <1000rpm VTEC works :tdvtec: .
     
  13. toby87 Top Contributor ★ ★ ★ ★ ☆

    615
    Could be coolant temp sensor, VTEC normally only works over 60*c but this can be disabled in the map although I have no idea if H-tune do this, would also explain the high idle.
     
  14. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    yeah i wonder if it might be that, but why would it stop idling high and work fine after i've reset the car by turning the ignition on and off.


    the idle speed never drops until its been restarted even with the temp gauge sat in the centre of the gauge.


    it doesnt warm up very quickly and i've tried two differnt chips now with the same results.
     
  15. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    tried a different h tune chip, exactly the same problem,


    could it be the idle speed control valve??
     
  16. EJ9_B18_DMS Club Member ★ ☆ ☆ ☆ ☆

    the IACV you mean?


    its worth a look


    im doing the same swap :thumbs:
     
  17. noname29 Top Contributor ★ ★ ★ ★ ☆

    if idle temp stays over 750rpm after warm up then it good to have a look at the IACV cheers
     
  18. turbofish Club Member ★ ☆ ☆ ☆ ☆

    122
    replaced the IACV with one off my friends car problem is still the same tried a different ECU with my chip in it still exactly the same, did notice the coolant temp gauge was playing about moving slightly up and down.


    unplugged the coolant temp sensor and it made no differnce, no CEL light came on also the coolant fan is running alot of the time.


    what other sensors does it use for coolant temp??
     
  19. SimpsonAE86 New Member Getting Started

    2
    Hey mate.was just wondering how your goin with this problem,have you had any luck in sorting it out?i have a 96 EK hatch with a b16a JDM transplant and im having the EXACT same problem as you.cheers Andy.
     
  20. sj4x4 Senior Member ★ ★ ☆ ☆ ☆

    No mate ha hasn't sorted it