Engine & Gearbox 2002 Acdord 1.8 sport throttle suck open servo failure

Discussion in 'Honda F/H-Series' started by smbell100, Saturday 31st Aug, 2013.

  1. smbell100 Junior Member ☆ ☆ ☆ ☆ ☆

    2002 Acdord 1.8 sport throttle stuck open servo failure - Solved

    I brought this car second hand about a month ago, with no serivce history. It has been fitted with a new induction kit.

    For a couple of weeks I have had an engine warning light, the code indicating EGR valve problems. The engine starts from cold ok, but won;t tick over when warm. On the way to work this morning the throttle stuck wide open and a few seconds later the brake servo failed. Opening the bonnet, I could see that the throttle cable was returning correctly, the servo looks like new, and all the hoses look new as well.

    Has anyone any suggestions about where to start looking. Many thanks


    Problem solved. The air inlet and filter had been replaced. When the filter was fitted (one of those universal conical jobs with extra gaskets) one of the gaskets was left in the air intake. It was sucked into the throttle valve and jammed it open.

    Many thanks for the help

    Last edited: Sunday 8th Sep, 2013
  2. AndyB1976 Valued Contributor ★ ★ ★ ★ ☆

    United Kingdom Andy Aberfoyle
    Hello, welcome to AOC.

    Do you have anymore codes? Have you tried to clean the EGR and ports? Have you had a look at/cleaned the throttle body, maybe a possible vacuum leak affecting it and the servo?
  3. smbell100 Junior Member ☆ ☆ ☆ ☆ ☆

    I didn't have a lot of time when I got to work. Will be looking at it again tomorrow.

    Thanks for the reply